EPICS Home

Experimental Physics and Industrial Control System


 
1994  1995  1996  1997  1998  1999  <20002001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020  2021  2022  Index 1994  1995  1996  1997  1998  1999  <20002001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020  2021  2022 
<== Date ==> <== Thread ==>

Subject: Re: forcing binary output value at initialization
From: [email protected] (William Lupton)
To: [email protected], [email protected], [email protected]
Date: Mon, 24 Apr 2000 08:27:19 -1000
...and yes, at Keck we do have a modified version of the Xy240 driver that
uses a configuration routine as suggested by Andrew J. Its signature is:

void xy240Configure(
    int         cardNum,        /* card number as used in INP fields */
    void        *base,          /* base address of the board */
    int         vectorNum,      /* interrupt vector number. If 0 then one */
                                /* will be found */

    int         itrLevel,       /* board's interrupt level */
    int         itrState,       /* whether or not interrupts should be */
                                /* enabled at init time specified as the */
                                /* mask for the 8 interrupt signals */

    int         scanState,      /* whether or not the input scan task */
                                /* should be spawned at init time */

    int         portConfig,     /* specifies port i/o direction */
                                /* configuration */

    int         presetFlag,     /* specified whether or not output ports */
                                /* should be preset on init */

    int         presetValues
);

Allan Honey (the sender of the previous message) is the one to contact for
further information. We should get our local EPICS web site in order, plus
make sure that our drivers etc. are on the "EPICS supported hardware" list
(not all are).

The device support does not seem to honor readback of initial values, i.e.
the "return 0 to request rval -> val conversion" protocol. Presumably
this behavior could be controlled by another argument to the configuration
routine and/or some extra bits in the "presetFlag" argument.

William


Navigate by Date:
Prev: Re: forcing binary output value at initialization Allan Honey
Next: Slow booting IOCs Geoff Savage
Index: 1994  1995  1996  1997  1998  1999  <20002001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020  2021  2022 
Navigate by Thread:
Prev: Re: forcing binary output value at initialization Allan Honey
Next: mpfGpib Marty Kraimer
Index: 1994  1995  1996  1997  1998  1999  <20002001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020  2021  2022