EPICS Home

Experimental Physics and Industrial Control System


 
1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  <20142015  2016  2017  2018  2019  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  <20142015  2016  2017  2018  2019 
<== Date ==> <== Thread ==>

Subject: Re: make extensions error
From: Hinko Kocevar <hinkocevar@gmail.com>
To: GUO Zhiying <zyguo@ihep.ac.cn>
Cc: tech-talk@aps.anl.gov
Date: Tue, 27 May 2014 19:38:41 +0200
Hi Guo,

you are missing X11 development packages:

> ../xwd2ps.h:53:22: warning: X11/Xlib.h: No such file or directory

On Redhat based systems you can use yum utility to find out which RPM provides the missing files.
Usually you need to look for packages that have ‘-devel' in their name since those are the ones providing development headers.
For example on my Scientific Linux install I get these results when looking for *X11/Xlib.h:

[devenv@localhost ~]$ yum provides *X11/Xlib.h
Loaded plugins: refresh-packagekit, security
ESS-custom/filelists                                     | 6.3 kB     00:00     
codac4.1-deps/filelists                                  |  64 kB     00:00     
libX11-devel-1.3-2.el6.i686 : Development files for libX11
Repo        : sl6.3-x86_64
Matched from:
Filename    : /usr/include/X11/Xlib.h



libX11-devel-1.3-2.el6.x86_64 : Development files for libX11
Repo        : sl6.3-x86_64
Matched from:
Filename    : /usr/include/X11/Xlib.h



libX11-devel-1.3-2.el6.x86_64 : Development files for libX11
Repo        : installed
Matched from:
Filename    : /usr/include/X11/Xlib.h

Hope that helps!

/Hinko




On 23 May 2014, at 14:21, GUO Zhiying <zyguo@ihep.ac.cn> wrote:

> Hi Everyone,
> 
> I am new to EPICS and i am trying to install EPICS extensions on Red Hat Enterprise Linux Workstation 6.1. The epics base has been installed.
> when I run make at the top level of extensions,it terminates with following 
> errors:
> 
> make -C ./configure install 
> make[1]: Entering directory `/usr/epics/extensions/configure'
> make -C O.linux-x86 -f ../Makefile TOP=../.. T_A=linux-x86 install
> make[2]: Entering directory `/usr/epics/extensions/configure/O.linux-x86'
> make[2]: Nothing to be done for `install'.
> make[2]: Leaving directory `/usr/epics/extensions/configure/O.linux-x86'
> make[1]: Leaving directory `/usr/epics/extensions/configure'
> make -C ./src install 
> make[1]: Entering directory `/usr/epics/extensions/src'
> make -C ./medm install 
> make[2]: Entering directory `/usr/epics/extensions/src/medm'
> make -C ./printUtils install 
> make[3]: Entering directory `/usr/epics/extensions/src/medm/printUtils'
> make -C O.linux-x86 -f ../Makefile TOP=../../../.. T_A=linux-x86 install
> make[4]: Entering directory `/usr/epics/extensions/src/medm/printUtils/O.linux-x86'
> 
> /usr/bin/gcc -c  -D_POSIX_C_SOURCE=199506L -D_POSIX_THREADS -D_XOPEN_SOURCE=500           -D_X86_  -DUNIX  -D_BSD_SOURCE -Dlinux  -D_REENTRANT   -O3 -g   -Wall      -m32     -fPIC -MMD -I. -I../O.Common -I. -I.. -I../../../../include/os/Linux -I../../../../include -I/usr/epics/base/include/os/Linux -I/usr/epics/base/include        -I/usr/include   ../ps_utils.c 
> In file included from ../printUtils.h:13,
>                 from ../ps_utils.c:28:
> ../xwd2ps.h:53:22: warning: X11/Xlib.h: No such file or directory
> In file included from ../ps_utils.c:28:
> ../printUtils.h:24: error: expected ‘)’ before ‘*’ token
> make[4]: *** [ps_utils.o] Error 1
> make[4]: Leaving directory `/usr/epics/extensions/src/medm/printUtils/O.linux-x86'
> make[3]: *** [install.linux-x86] Error 2
> make[3]: Leaving directory `/usr/epics/extensions/src/medm/printUtils'
> make[2]: *** [printUtils.install] Error 2
> make[2]: Leaving directory `/usr/epics/extensions/src/medm'
> make[1]: *** [medm.install] Error 2
> make[1]: Leaving directory `/usr/epics/extensions/src'
> make: *** [src.install] Error 2
> 
> Please help me in finding the problem and its solution.
> 
> 



References:
make extensions error GUO Zhiying

Navigate by Date:
Prev: Job opportunities at ESS Timo Korhonen
Next: Re: how to know which PVs write to a PV Andrew Johnson
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  <20142015  2016  2017  2018  2019 
Navigate by Thread:
Prev: make extensions error GUO Zhiying
Next: how can I caget a PV's Value in the callback function of the caClient? ahwwq
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  <20142015  2016  2017  2018  2019