EPICS Home

Experimental Physics and Industrial Control System


 
1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  <20132014  2015  2016  2017  2018  2019  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  <20132014  2015  2016  2017  2018  2019 
<== Date ==> <== Thread ==>

Subject: Re:
From: Andrew Johnson <anj@aps.anl.gov>
To: "Andrew C. Starritt" <Andrew.Starritt@synchrotron.org.au>
Cc: tech-talk <tech-talk@aps.anl.gov>
Date: Sat, 6 Jul 2013 12:30:44 -0500 (CDT)
Hi Andrew,

This is not an intentional feature, but according to Janet Anderson it is a side-effect of our inclusion of .. in the list of paths that we're configuring vpath for the .db target. Apparently the vpath gets applied to targets as well as sources by GNUMake, and it causes this to happen because we use vpath to avoid having to duplicate some of the build rules.

I have asked Janet to look at how many rules would need to be added to remove .. from the vpath list and we'll probably make that change on the 3.15 branch, but I think it's probably too big a change to do in 3.14.

Thanks for the report, is this going to be a significant issue for you at all?

- Andrew

-- 
Sent from my iPad

On Jul 4, 2013, at 8:52 PM, "Andrew C. Starritt" <Andrew.Starritt@synchrotron.org.au> wrote:

> Hi all,
> 
> I found some strange build behaviour (on both base-3.14.12.3 using 64 bit CentOs 5.9
> and base-3.14.9 using 32 bit CentOs 5.4). If there is a db directory in top's parent
> directory that contains a file with the same name as I'm trying to install into
> the top's db directory, then the install does not happen.
> 
> The following demonstrates this:
> 
> cd /tmp
> mkdir -p above_top/top
> cd above_top/top
> makeBaseApp.pl -t ioc Weird
> cd WeirdApp/Db/
> vi Makefile            # uncomment the DB += xxx.db line
> touch xxx.db
> cd ../..               # back to top
> make
> ls -l db               # the xxx.db file installed as expected - so far so good.
> make clean uninstall
> 
> # and the weirdness starts here:
> #
> mkdir ../db
> touch ../db/xxx.db
> make
> ls -l                  # no db diretory in top, and no installed xxx.db file.
> 
> 
> Is this an intended feature, and if so what is the rationale?
> 
> Regards
> 
> --
> Andrew Starritt | Principal Controls Engineer | Australian Synchrotron
> p: (03) 8540 4164 | f: (03) 8540 4200
> andrew.starritt@synchrotron.org.au | www.synchrotron.org.au
> 800 Blackburn Road, Clayton, Victoria 3168
> 


Replies:
RE: weird build Andrew C. Starritt
References:
[no subject] Andrew C. Starritt

Navigate by Date:
Prev: Re: pvGet timeout in sequencer 2.1.12 Benjamin Franksen
Next: Re: asyn+streamDevice hangs with synchronousLock:Yes Brian McAllister
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  <20132014  2015  2016  2017  2018  2019 
Navigate by Thread:
Prev: [no subject] Andrew C. Starritt
Next: RE: weird build Andrew C. Starritt
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  <20132014  2015  2016  2017  2018  2019