Argonne National Laboratory

Experimental Physics and
Industrial Control System

2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020  2021  Index 2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020  2021 
<== Date ==> <== Thread ==>

Subject: Problem with performstruct test
From: Dirk Zimoch <dirk.zimoch@psi.ch>
To: EPICS Core Talk <core-talk@aps.anl.gov>
Date: Wed, 19 Sep 2018 10:01:10 +0200
Hello,

In pvData/testApp/pv is a test "performstruct" which uses clock_gettime(). With older glibc versions it is required to link this with "rt". Thus I have added

performstruct_SYS_LIBS_Linux += rt

to pvData/testApp/pv/Makefile.

Then I recognized that all the other tests in the Makefile have a line

TESTS += ...

but performstruct has not. Is this a bug?

Dirk

Replies:
Re: Problem with performstruct test Dirk Zimoch

Navigate by Date:
Prev: parallel builds and O.Common Benjamin Franksen
Next: Re: Problem with performstruct test Dirk Zimoch
Index: 2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020  2021 
Navigate by Thread:
Prev: parallel builds and O.Common Benjamin Franksen
Next: Re: Problem with performstruct test Dirk Zimoch
Index: 2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020  2021 
ANJ, 19 Sep 2018 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·