Argonne National Laboratory

Experimental Physics and
Industrial Control System

2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  <2020 Index 2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  <2020
<== Date ==> <== Thread ==>

Subject: C++ standards discussion
From: Timo Korhonen via Core-talk <core-talk at aps.anl.gov>
To: EPICS Core Talk <core-talk at aps.anl.gov>
Date: Fri, 2 Oct 2020 09:29:00 +0000

Colleagues,

 

We had recently (if you can still call that “recent”) some discussion about which C++ standards would be required/accepted/recommended. Would somebody be so kind and help me refresh my memory where we ended with the discussion?

 

I remember that we stated that C++11 (compiler/toolchain) will be a requirement for EPICS 7.1 onwards. But were there any statements about C++14, C++17, and further? Anything more concrete than “we are looking into the issue”?

 

Why am I asking? We have many contributors in our (ESS) collaborating institutes, some of them very innovative 😉 and we would like to give them some rules and guidelines when they write code for ESS and possibly wider purposes.

 

At the moment it seems to me to say that it is OK to use C++11 features. Code that is not strictly limited to ESS applications (e.g., modules that might be contributed to the community) should not use newer features until further notice – I think?

Then we have to see what we can support internally at ESS but that is another thing.

 

Timo

 


Replies:
Re: C++ standards discussion Ralph Lange via Core-talk
Re: C++ standards discussion Mark Rivers via Core-talk
Re: C++ standards discussion Konrad, Martin via Core-talk

Navigate by Date:
Prev: Build failed: epics-base base-integration-590 AppVeyor via Core-talk
Next: Re: C++ standards discussion Ralph Lange via Core-talk
Index: 2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  <2020
Navigate by Thread:
Prev: Build failed: epics-base base-integration-590 AppVeyor via Core-talk
Next: Re: C++ standards discussion Ralph Lange via Core-talk
Index: 2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  <2020
ANJ, 02 Oct 2020 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·