Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018 
<== Date ==> <== Thread ==>

Subject: Update of cross compilers for Linux released
From: "David H. Thompson" <thompsondh@ornl.gov>
To: techtalk <tech-talk@aps.anl.gov>
Date: Fri, 07 Mar 2003 09:17:18 -0500
Greetings:

I have updated and revised the build system for the gcc cross compiler for
Tornado 2.0.2 and Tornado 2.2 on Linux. In addition, several support files
have been added to make kernel building possible on the WRS unsupported
Linux platform.  The completed installation matches that of a normal WRS
installation on other platforms and minimizes changes that need to be made
to the configure files in Epics base.

The 2.9.6 compiler for T2.2 will build a kernel and bootroms as is, the
2.7.2 compiler for T202 is missing a tool needed to extract a bootrom image
from the bootrom object file. There are some additional files in
vxWorks-kit.tgz including the objcopyppc binary from the 2.9.6 compiler.
With a change in the BSP Makefile objcopyppc can be used to extract a
bootrom image with the T202 compiler chain.

Please let me know if you download and use these compilers.

The tar files are now located on our group's web server:
http://ics-web1.sns.ornl.gov/share/crossGCC/.
Thanks to Richard Dabney at lanl for elfXsyms.

Dave Thompson thompsondh@ornl.gov.


Navigate by Date:
Prev: Re: Long expressions using MAX and MIN in CALC fields Tim Mooney
Next: Ethernet driver needed, Omega CNi1622 Pam Gurd
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018 
Navigate by Thread:
Prev: RE: Any modern solution besides the TVs and EPICS alarm handler ? Pete R Jemian
Next: Ethernet driver needed, Omega CNi1622 Pam Gurd
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018 
ANJ, 10 Aug 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·