Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
<== Date ==> <== Thread ==>

Subject: RE: Problems using Epics R3.14.3 with mvme5110 PowerPc
From: "Jeff Hill" <johill@lanl.gov>
To: "'Dennis Armstrong'" <dba@ing.iac.es>, <tech-talk@aps.anl.gov>
Date: Tue, 16 Sep 2003 08:43:44 -0600
Hello Dennis,

> I tried to telnet to port 5064 on the IOC but it reports connection
> refused. It looks like the IOC isn't listening on this port.
> The only tcp ports it recognizes are 23, 111 and 513
> Any suggestions as to what's missing in the IOC?

Type "inetstatShow". On a normal EPICS system you will see CA's TCP daemon
listening on port 5064, but based on your experiments so far I am guessing
that you will not. On a normal system there will also be a UDP server socket
attached to port 5064. 

Type "spyClkStart" followed by "spyReport". I am going to guess that there
is a thread in the system that is using 100% of the CPU. This might be a
device driver or the processing load of a large database.

If that isn't the cause, then please check to see if there are any error
messages when iocInit runs, when your application loads, or when your
application is compiled and linked. 

Jeff

> -----Original Message-----
> From: Dennis Armstrong [mailto:dba@ing.iac.es]
> Sent: Tuesday, September 16, 2003 7:32 AM
> To: tech-talk@aps.anl.gov
> Subject: Problems using Epics R3.14.3 with mvme5110 PowerPc
> 
> Hi all
> 
> I am having trouble connecting to our new PowerPc card using EPICS
> r3.14.3.
> 
> I have built EPICS base and some of the extensions.
> 
> I can boot the ioc with an epics database (the demo.db one fron the
> sequencer extension)
> I can access the datebase when logged into the ioc from a console ie
> dbpf, dbgf and dbl commands all work
> and I can access the various pv fields.
> 
> I cannot access the database from outside the ioc using caget or medm.
> caget returns an "Invalid channel name" when
> accessing any of the PowerPC PV's although it is quite happy to access
> the other iocs running EPICS R3.13.1
> 
> I tried to telnet to port 5064 on the ioc but it reports connection
> refused. It looks like the ioc isn't listening on this port.
> The only tcp ports it recognises are  23,  111 and  513
> Any suggestions as to whats missing in the ioc?
> 
> regards
> 
> Dennis Armstrong
> 
> 
> 
> 




Replies:
Re: Problems using Epics R3.14.3 with mvme5110 PowerPc Dennis Armstrong
References:
Problems using Epics R3.14.3 with mvme5110 PowerPc Dennis Armstrong

Navigate by Date:
Prev: Problems using Epics R3.14.3 with mvme5110 PowerPc Dennis Armstrong
Next: about edm zhaozhuo
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
Navigate by Thread:
Prev: Problems using Epics R3.14.3 with mvme5110 PowerPc Dennis Armstrong
Next: Re: Problems using Epics R3.14.3 with mvme5110 PowerPc Dennis Armstrong
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
ANJ, 10 Aug 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·