Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
<== Date ==> <== Thread ==>

Subject: RE: archive viewer installation problem
From: "Chevtsov, Sergei" <chevtsov@slac.stanford.edu>
To: "Claude Saunders" <saunders@aps.anl.gov>, "Christophe Moins" <moins@ego-gw.it>
Cc: <tech-talk@aps.anl.gov>
Date: Fri, 2 Sep 2005 16:17:00 -0700
Hi, Christophe!

Claude is correct, and I apologize for not testing the new build under 1.4 :-(
Unfortunately, I have no access to SNS CVS right now, so I will be able to fix it only when I am back from my vacation next Wednesday.

To all:
Btw, how many people still use Java 1.4?

Sergei

-----Original Message-----
From: Claude Saunders [mailto:saunders@aps.anl.gov]
Sent: Fri 9/2/2005 9:08 AM
To: Christophe Moins
Cc: tech-talk@aps.anl.gov
Subject: Re: archive viewer installation problem
 
This looks very much like the xal.jar (and hence MessageCenter.class) 
was built with JDK1.5, whereas you are compiling and building with 
JDK1.4. I've used classes across the transition from JDK1.3 to JDK1.4 
before without a problem, but it looks like there are more 
incompatibilities between 1.4 and 1.5. It's nice that the compiler flags 
it, but the error message is a bit obtuse.

SNS builds XAL with JDK1.5 now, so you either have to move up to 1.5, or 
request a jar file built under 1.4. I'm not sure if they have coded in 
1.5 specific features, so that may or may not be possible.

   - Claude

Christophe Moins wrote:

> Hello,
>
> I am trying to install archive viewer but I have the following message 
> when I launch the ant command in  Archiveviewer's top directory :
>
> *********************************************************************************************************** 
>
> Buildfile: build.xml
>
> -create_build_dir:
>
> build_all:
>    [javac] Compiling 842 source files to /root/archiveviewer/build
>    [javac] 
> /root/archiveviewer/src/epics/archiveviewer/base/AVBase.java:25: 
> cannot access gov.sns.tools.messaging.MessageCenter
>    [javac] bad class file: 
> /root/archiveviewer/ext_jars/xal.jar(gov/sns/tools/messaging/MessageCenter.class) 
>
>    [javac] class file has wrong version 49.0, should be 48.0
>    [javac] Please remove or make sure it appears in the correct 
> subdirectory of the classpath.
>    [javac] import gov.sns.tools.messaging.MessageCenter;
>    [javac]                                ^
>    [javac] 1 error
>
> BUILD FAILED
> /root/archiveviewer/build.xml:21: Compile failed; see the compiler 
> error output for details.
>
> Total time: 18 seconds
> *********************************************************************************************************** 
>
>
>
> Does anybody what's going on ?
>
> Thanks
> Christophe
>




Replies:
Re: archive viewer installation problem Sergei Chevtsov

Navigate by Date:
Prev: Call for Volunteers: 3.13 Record Reference Manual Andrew Johnson
Next: Re: SNCSEQ... Emmanuel Mayssat
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
Navigate by Thread:
Prev: Re: archive viewer installation problem Claude Saunders
Next: Re: archive viewer installation problem Sergei Chevtsov
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
ANJ, 02 Sep 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·