Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  <20112012  2013  2014  2015  2016  2017  2018  2019  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  <20112012  2013  2014  2015  2016  2017  2018  2019 
<== Date ==> <== Thread ==>

Subject: RE: Gateway/CAS "bad resource" with CAJ?
From: "Jeff Hill" <johill@lanl.gov>
To: "'Kasemir, Kay'" <kasemirk@ornl.gov>, "'TechTalk'" <tech-talk@aps.anl.gov>
Date: Mon, 7 Mar 2011 09:39:40 -0700
Hi Kay,

> Bad resource identifier - unexpected problem with client's input - forcing
> disconnect

I don?t claim to fully understand at this point what's occurring; I created
bug entry 730720 at launchpad so we can work the issue.

Jeff
______________________________________________________
Jeffrey O. Hill           Email        johill@lanl.gov
LANL MS H820              Voice        505 665 1831
Los Alamos NM 87545 USA   FAX          505 665 5107

Message content: TSPA

With sufficient thrust, pigs fly just fine. However, this is
not necessarily a good idea. It is hard to be sure where they
are going to land, and it could be dangerous sitting under them
as they fly overhead. -- RFC 1925


> -----Original Message-----
> From: tech-talk-bounces@aps.anl.gov [mailto:tech-talk-bounces@aps.anl.gov]
> On Behalf Of Kasemir, Kay
> Sent: Friday, March 04, 2011 11:37 AM
> To: TechTalk
> Subject: Gateway/CAS "bad resource" with CAJ?
> 
> Hello:
> 
> For what it's worth, we're seeing these messages on a CA Gateway at the
> SNS:
> 
> -------------
> CAS Request: ... on ....: cmd=2 cid=1 typ=20 cnt=1 psz=0 avail=130
> CAS:
> 
> Mar 04 08:20:39 !!! Errlog message received (message is above)
> bad resource id in "../../../../src/cas/generic/casStrmClient.cc" at line
> 1988
> 
> Mar 04 08:20:39 !!! Errlog message received (message is above)
> filename="../../../../src/cas/generic/st/casStreamOS.cc" line number=479
> Bad resource identifier - unexpected problem with client's input - forcing
> disconnect
> -------------
> 
> The messages appear to be caused by pure Java (CAJ) clients running on
> Windows, Linux and Mac OS X.
> 
> The gateway is version 2.0.4.0, based on EPICS R3.14.11.
> CAJ is 1.1.7 with JCA 2.3.3 to 2.3.5 depending on the specific client,
> can't
> say for sure which one is which.
> 
> We are not sure it's a severe problem. The gateway continues to run.
> Since we don't use CAJ on the accelerator network, only on the office
> network where all access is through a read-only gateway, we can't spend
> much
> time on debugging this issue, but sites that depend on CAJ for a
> production
> setup might want to check if they get similar messages.
> 
> Thanks,
> Kay




Replies:
Re: Gateway/CAS "bad resource" with CAJ? Steven M. Hartman
References:
Gateway/CAS "bad resource" with CAJ? Kasemir, Kay

Navigate by Date:
Prev: Re: Setting inter-character delay in Asyn Eric Norum
Next: Re: Gateway/CAS "bad resource" with CAJ? Steven M. Hartman
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  <20112012  2013  2014  2015  2016  2017  2018  2019 
Navigate by Thread:
Prev: Gateway/CAS "bad resource" with CAJ? Kasemir, Kay
Next: Re: Gateway/CAS "bad resource" with CAJ? Steven M. Hartman
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  <20112012  2013  2014  2015  2016  2017  2018  2019 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·