Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019 
<== Date ==> <== Thread ==>

Subject: RE: Large waveform PV through CA Gateway
From: "Chen, Xihui" <chenx1@ornl.gov>
To: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Mon, 25 Jun 2012 11:17:12 -0400
Thanks for all the quick replies! Looks like this is a common issue and Jeff just have created a bug entry for it.

Regards,
Xihui 

________________________________________
From: Hill, Jeff [johill@lanl.gov]
Sent: Monday, June 25, 2012 11:11 AM
To: Chen, Xihui
Subject: RE: Large waveform PV through CA Gateway

I created bug entry 1017549. Note that Peng Sheng (of SLAC) is also
looking into this issue.

Jeff
________________________________________
From: Bertrand Alain Gregor [alain.bertrand@psi.ch]
Sent: Monday, June 25, 2012 11:07 AM
To: Chen, Xihui; tech-talk@aps.anl.gov
Subject: RE: Large waveform PV through CA Gateway

Hi Xihui,

We have the exact same kind of issues with the current EPICS Gateway,
basically my understanding of the problem is that the gateway must wait
till all the IP packet for a given EPICS message came in, before being
able to re-construct the value in the "Server" part of the gateway and
only then send the event to the clients that a new value is there. This
introduce of course some latency.

Due to this issue and others, we are currently developing a gateway
implementation which works with a different approach and the initial
tests are promising.

Sincerely,

Alain Bertrand

-----Original Message-----
From: tech-talk-bounces@aps.anl.gov
[mailto:tech-talk-bounces@aps.anl.gov] On Behalf Of Chen, Xihui
Sent: Monday, June 25, 2012 16:50
To: tech-talk@aps.anl.gov
Subject: Large waveform PV through CA Gateway

Hi,

I have a performance issue with transferring large image PV(2048*2048 at
1hz) through CA gateway. Without CA gateway, the client are able to
update at 1hz, but with ca gateway, it can only get updates every 10
second. The CPU usage on IOC, gateway and client are all very low. I
want to know if anyone has similar experience?

Thanks,
Xihui



References:
Large waveform PV through CA Gateway Chen, Xihui
RE: Large waveform PV through CA Gateway Bertrand Alain Gregor

Navigate by Date:
Prev: RE: Large waveform PV through CA Gateway Bertrand Alain Gregor
Next: Re: XOFF Problem with tyGSOctal Eric Norum
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019 
Navigate by Thread:
Prev: RE: Large waveform PV through CA Gateway Bertrand Alain Gregor
Next: FW: Large waveform PV through CA Gateway Hill, Jeff
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·