Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019 
<== Date ==> <== Thread ==>

Subject: Re: LabVIEW EPICS connection
From: Paul Sichta <psichta@pppl.gov>
To: Steve Kinder <steve@dsoft-solutions.co.uk>
Cc: Stephen DeLuca <sdeluca@pppl.gov>, tech-talk <tech-talk@aps.anl.gov>
Date: Thu, 28 Jun 2012 09:56:24 -0400
Steve K.,
Steve D. (here at PPPL) has successfully brought up two LabVIEW
systems recently that use the latest NI release and EPICS client
package.  NI's documentation could be improved, they seem to have
several versions/EPICS packages with similar and confusing names.  To
build an executable you need a DSC run-time license.  Our EPICS comm
is very modest, a couple hundred records in a 1 Hz poll.  No arrays
attempted.  Steve can give you example code/snippets and tips, if
interested.

I have mildy griped to NI about these issues.  They make it more
difficult than it seems it should be,  I didn't consider CAlab, as I
thought NI would have gotten it right (this time).

-ps




On Thu, Jun 28, 2012 at 5:02 AM, Steve Kinder
<steve@dsoft-solutions.co.uk> wrote:
> I am trying to connect an existing LabVIEW VI to EPICS via the freely
> available LabVIEW add-on EPICS Client I/O Server
> (http://joule.ni.com/nidu/cds/view/p/id/2533/lang/en). I am running LabVIEW
> 2011 and have a 3-14-11 soft IOC running on the same system with a few test
> PVs. My first aim is to make a connection between these PVs and elements of
> the LabVIEW VI (currently just a test VI). I wondered whether anyone had
> successfully used this LabVIEW add-on or the full version as in the DSC/RT
> add-ons and could offer me advice on how to make the connection.
>
> I have the following in my test LabVIEW VI; Create EPICS VI, Deploy EPICS
> Client VI and List Records VI. I was hoping that the latter would display a
> list of records in my soft IOC if the connection had been established. I get
> no errors but it doesn’t seem to display any records.
>
> Any advice would be appreciated, perhaps including whether I should be
> trying to use this LabVIEW add-on or one of the other options e.g. CA Lab or
> the Oak Ridge CA client.
>
> Many Thanks
>
> Steve
>


References:
LabVIEW EPICS connection Steve Kinder

Navigate by Date:
Prev: Re: XOFF Problem with tyGSOctal Dirk Zimoch
Next: RE: caget limitation retreiving ENUM list Hill, Jeff
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019 
Navigate by Thread:
Prev: RE: LabVIEW EPICS connection ulrik.pedersen
Next: Re: LabVIEW EPICS connection Dale L. Brewe
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·