EPICS Controls Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019  2020  2021  2022  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019  2020  2021  2022 
<== Date ==> <== Thread ==>

Subject: Re: 3.14 v.s. 3.15 vs. v4
From: Jack Smith <[email protected]>
To: Andrew Johnson <[email protected]>
Cc: [email protected]
Date: Wed, 21 Nov 2012 15:54:17 -0500
Hi Andrew,

Thanks for pointing out the new features in the Base 3.15.

I'm very surprised by the chart "Accelerator IOC EPICS Versions" in
your presentation: ~60% IOCs were using aged version 3.13 in March,
2011 and 25% in Sept. 2012. I always think that APS is the pioneer in
the EPICS base. But after seeing this chart, I think that APS is
pioneering in the base development rather than the deployment. Could
anyone share your experience and opinion why it is so difficult to
upgrade the legacy to the up-to-date?

Thanks,

Jack

On Thu, Nov 1, 2012 at 4:15 PM, Andrew Johnson <[email protected]> wrote:
> Hi Jack,
>
> On 2012-10-30 Jack Smith wrote:
>> One of the major achievements in 3.14 is the
>> introduction of the OSI which supports iocCore on platforms besides
>> vxWorks. What kind of "breakthrough" is in 3.15, the post pi era of
>> EPICS? Are there any fundamental changes/improvements on the iocCore
>> and Channel access?
>
> I gave a talk and demo at the EPICS Collaboration Meeting in Korea last week
> that briefly covers the major changes. Until all the presentations get
> uploaded to the meeting website at PAL (linked from the Meetings page on the
> EPICS website) you can find my slides at
>   http://www.aps.anl.gov/epics/meetings/2012-10/talks/V3-Directions.pdf
> The 3.15 demo database that I used contains some instructions in comment lines
> (some are IOC commands, others are for the Unix shell) and is available at
>   http://www.aps.anl.gov/epics/meetings/2012-10/talks/V3-demo.db
> but you'll have to delete the printf record instance from the file since that
> record type hasn't been merged into the 3.15 branch yet.  You might have to
> use a fairly recent version of Base from the 3.15 branch instead of the
> 3.15.0.1 release to actually run this, although I don't see any obvious
> reasons for that at the moment.
>
> HTH,
>
> - Andrew


Replies:
Re: 3.14 v.s. 3.15 vs. v4 Pete Jemian
References:
3.14 v.s. 3.15 vs. v4 Jack Smith
Re: 3.14 v.s. 3.15 vs. v4 Andrew Johnson

Navigate by Date:
Prev: caRepeater object code not cross-compiled in R3.14.12.2 Rod Nussbaumer
Next: Re: 3.14 v.s. 3.15 vs. v4 Pete Jemian
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019  2020  2021  2022 
Navigate by Thread:
Prev: Re: 3.14 v.s. 3.15 vs. v4 Andrew Johnson
Next: Re: 3.14 v.s. 3.15 vs. v4 Pete Jemian
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019  2020  2021  2022 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·