Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  <20132014  2015  2016  2017  2018  2019  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  <20132014  2015  2016  2017  2018  2019 
<== Date ==> <== Thread ==>

Subject: RE: EPICS on RTEMS 4.11
From: Nadia Gruman <Nadia.Gruman@pro-dex.com>
To: Kate Feng <kate007.feng@gmail.com>
Cc: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Mon, 2 Dec 2013 19:21:37 +0000
Kate, 

I used the configuration in the post and was able to build RTEMS, but the addon package was still failing, so I abandoned the attempts to make it work with 4.11 and followed these instructions to build for 4.10.2 and it worked perfectly on the first try. 

Thank for your help!

Nadia. 



From: Kate Feng [kate007.feng@gmail.com]
Sent: Monday, December 02, 2013 5:40 AM
To: Till Straumann
Cc: Nadia Gruman; tech-talk@aps.anl.gov
Subject: Re: EPICS on RTEMS 4.11

The question and answer are posted at RTEMS.  One example is at :
http://www.rtems.org/pipermail/rtems-users/2013-November/012218.html

Cheers,
Kate Feng


On Wed, Nov 27, 2013 at 2:45 AM, Till Straumann <strauman@slac.stanford.edu> wrote:
Nadia.

If you seek help then I suggest you provide as much information
about your situation as possible along with your request.

"I have a problem, please help"

does not give us any clue as to what exactly you were trying to do
and what exactly went wrong. Chances to get a reply increase
if you give more details. At the least, I recommend to attach a
***complete*** log of your failed attempt to build.

Please don't make the common mistake to just copy/paste the
few lines where the actual failure happens. It is very important that
you provide a complete log because in many cases the cause
for the failure can be determined from information that is contained
somewhere in the log (but not in the excerpt which the novice
solely believes to be relevant).

Good luck
- Till


On 11/27/2013 12:19 AM, Nadia Gruman wrote:
Hello all, 

Is anyone using EPICS with RTEMS 4.11? I am trying to build it for use with MVME5500, but I'm running into some issues and wondering if I should use 4.10. 

There are compilation issues I ran into on Linux 12.04, plus there seem to be no rtems addon packages for 4.11 on their git site. 

Thank you, 

Nadia Gruman



References:
EPICS on RTEMS 4.11 Nadia Gruman
Re: EPICS on RTEMS 4.11 Till Straumann
Re: EPICS on RTEMS 4.11 Kate Feng

Navigate by Date:
Prev: Re: Fw: Alarm Handler Robert Soliday
Next: Base 3.14.12.4-rc1 available for testing Andrew Johnson
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  <20132014  2015  2016  2017  2018  2019 
Navigate by Thread:
Prev: Re: EPICS on RTEMS 4.11 Kate Feng
Next: Re: EPICS on RTEMS 4.11 Kate Feng
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  <20132014  2015  2016  2017  2018  2019 
ANJ, 20 Apr 2015 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·