Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  <20152016  2017  2018  2019  2020  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  <20152016  2017  2018  2019  2020 
<== Date ==> <== Thread ==>

Subject: Re: Text input to char waveform - bug? - Maybe SOLVED
From: Isabella Rey <isa.hellen@gmail.com>
To: "Summers, Tasha" <tsummers@bnl.gov>
Cc: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Thu, 26 Mar 2015 16:08:17 +0000
Hi Tasha,

Thank you for your reply.

Your solution works on my machine, but interestingly doesn't on my colleague's machine :)

We'll give it a go on other PCs, thanks!

Isabella



On 26 March 2015 at 15:13, Summers, Tasha <tsummers@bnl.gov> wrote:
We had the same problem with 3.2 and 3.3 on Debian. We fixed it by adding {"longString":true} after the PV name.

Doesn't work:
    PV Name: message1
Works:
    PV Name: message1 {"longString":true}

Hope this helps in your case,
Tasha

From: tech-talk-bounces@aps.anl.gov [tech-talk-bounces@aps.anl.gov] on behalf of Isabella Rey [isa.hellen@gmail.com]
Sent: Thursday, March 26, 2015 9:39 AM
To: tech-talk@aps.anl.gov
Subject: Re: Text input to char waveform - bug?

Hi All,

Did anybody get the chance to check this bug in Windows CSS?
Looks like I'm not the only one to have this problem.

Cheers,
Isabella

On 18 March 2015 at 13:39, Hinko Kocevar <hinkocevar@gmail.com> wrote:
Hi Isabella,

it does not work for me, too - but I’m using CSS 3.2.16 on Mac OS. Funny how it works for you on Linux..

What works for me is setting the PV text value using Probe View (not really a production solution).

Best regards,
Hinko

> On 18 Mar 2015, at 13:12, Isabella Rey <isa.hellen@gmail.com> wrote:
>
> Hi All,
>
> I'm running CSS 3.2.16 in Windows.
>
> I have a BOY text input widget that I want to use to write to a waveform of char, called TEST.
> The waveform is empty at startup.
> If I type something in the text input, like "abc", I get the following error message in the BOY Console:
>
> 2015-03-18 12:04:37 ERROR: Failed to write value to PV TEST from widget Text Input_1.
> Illegal input : abc
> java.lang.ArrayIndexOutOfBoundsException: 0
>
> If the waveform is not empty, the string gets updated correctly and there is no error.
>
> If I do the same in CSS in my Linux VM, all works fine, even at startup.
>
> Is this a bug in the Windows version or am I missing something?
>
> Thanks,
> Isabella




Navigate by Date:
Prev: RE: Text input to char waveform - bug? Summers, Tasha
Next: RE: Record issue - to set aother record value Mooney, Tim M.
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  <20152016  2017  2018  2019  2020 
Navigate by Thread:
Prev: RE: Record issue - to set aother record value Dalesio, Leo
Next: related to controls in edm priya tiwari
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  <20152016  2017  2018  2019  2020 
ANJ, 16 Dec 2015 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·