Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020 
<== Date ==> <== Thread ==>

Subject: Re: Problem when compiling devlib2 against EPICS 7
From: Benjamin Franksen <benjamin.franksen@helmholtz-berlin.de>
To: Jörn Dreyer <j.dreyer@hzdr.de>, <tech-talk@aps.anl.gov>
Date: Wed, 16 May 2018 15:44:19 +0200
On 05/16/2018 12:54 PM, Jörn Dreyer wrote:
> I encountered a Problem in the devlib2 code. It does not compile with EPICS7. 
> I had to apply this patch to get it compiling:
> 
> diff -Naur EPICS-7.0.1-org/modules/src/devlib2/exploreApp/src/
> devexplore_util.cpp EPICS-7.0.1/modules/src/devlib2/exploreApp/src/
> devexplore_util.cpp
> --- EPICS-7.0.1-org/modules/src/devlib2/exploreApp/src/devexplore_util.cpp      
> 2018-05-16 09:12:24.167857218 +0200
> +++ EPICS-7.0.1/modules/src/devlib2/exploreApp/src/devexplore_util.cpp  
> 2018-05-16 09:02:52.865400778 +0200
> @@ -5,6 +5,9 @@
>  
>  #include <epicsVersion.h>
>  #include <epicsStdlib.h>
> +#if EPICS_VERSION > 4
> +#include <errlog.h>
> +#endif

The #include here can and should be unconditional.

>  #define epicsExportSharedSymbols
>  #include "devexplore.h"
> @@ -32,7 +35,7 @@
>      }
>  }
>  
> -#if EPICS_REVISION<=14
> +#if EPICS_VERSION <= 3 && EPICS_REVISION<=14
>  
>  #define M_stdlib 4242
>  #define S_stdlib_noConversion (M_stdlib | 1) /* No digits to convert */
> 
> I used the actual code from github to be sure   not to miss any updates.

Attachment: signature.asc
Description: OpenPGP digital signature


Replies:
Re: Problem when compiling devlib2 against EPICS 7 Michael Davidsaver
References:
Problem when compiling devlib2 against EPICS 7 Jörn Dreyer

Navigate by Date:
Prev: Problem when compiling devlib2 against EPICS 7 Jörn Dreyer
Next: Re: Thorlabs FW102C Support? Brian Freeman
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020 
Navigate by Thread:
Prev: Problem when compiling devlib2 against EPICS 7 Jörn Dreyer
Next: Re: Problem when compiling devlib2 against EPICS 7 Michael Davidsaver
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020 
ANJ, 16 May 2018 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·