Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <2019 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <2019
<== Date ==> <== Thread ==>

Subject: modules/ca/src/perl cc1: error: ‘-fcf-protection=full’ on first build of base
From: Peter Milne via Tech-talk <tech-talk@aps.anl.gov>
To: Tech-talk <tech-talk@aps.anl.gov>
Date: Thu, 3 Jan 2019 09:33:15 +0000
Hello Tech-talk

Clean build fails first try on Fedora 28
Same result on 3.16

It's easily fixed, but is no one else using Fedora? :-(

Thanks

Peter

Procedure:
git clone https://github.com/epics-base/epics-base.git
cd epics-base/
git checkout -b 7.0.2
make

Error:
...
perl -CSD /usr/bin/xsubpp -typemap /usr/share/perl5/ExtUtils/typemap ../Cap5.xs > Cap5.c_new && mv Cap5.c_new Cap5.c
/usr/bin/gcc -D_GNU_SOURCE -D_DEFAULT_SOURCE -D_X86_64_ -DUNIX -Dlinux -O3 -g -Wall -D_REENTRANT -D_GNU_SOURCE -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fwrapv -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -mtune=generic -m64 -fPIC -I. -I../O.Common -I. -I. -I.. -I/home/pgm/PROJECTS/EPICS7/epics-base/include/compiler/gcc -I/home/pgm/PROJECTS/EPICS7/epics-base/include/os/Linux -I/home/pgm/PROJECTS/EPICS7/epics-base/include -I/home/pgm/PROJECTS/EPICS7/epics-base/include/compiler/gcc -I/home/pgm/PROJECTS/EPICS7/epics-base/include/os/Linux -I/home/pgm/PROJECTS/EPICS7/epics-base/include -I/usr/lib64/perl5/CORE -MM -MF Cap5.d Cap5.c
cc1: error: ‘-fcf-protection=full’ requires Intel CET support. Use -mcet or both of -mibt and -mshstk options to enable CET

Fix:
diff --git a/modules/ca/src/perl/Makefile b/modules/ca/src/perl/Makefile
index 5b2bd5920..39917a6bd 100644
--- a/modules/ca/src/perl/Makefile
+++ b/modules/ca/src/perl/Makefile
@@ -54,7 +54,8 @@ endif
 Cap5_SRCS = Cap5.xs
 Cap5_LIBS = ca Com
 Cap5_INCLUDES = -I$(shell $(PERL) ../perlConfig.pl archlib)/CORE
-Cap5_CFLAGS = $(shell $(PERL) ../perlConfig.pl ccflags)
+Cap5_CFLAGS =

Host system:
[pgm@hoy5 ~]$ cat /etc/redhat-release
Fedora release 28 (Twenty Eight)

[pgm@hoy5 ~]$ gcc -v
Using built-in specs.
..
gcc version 8.0.1 20180324 (Red Hat 8.0.1-0.20) (GCC)



https://epics.anl.gov seemed to be down the last couple days?. Nice to see it back up, thanks!

--
Peter Milne
Director of Sales
www.d-tacq.com

Replies:
Re: modules/ca/src/perl cc1: error: ‘-fcf-protection=full’ on first build of base Matt Newville via Tech-talk
Re: modules/ca/src/perl cc1: error: ‘-fcf-protection=full’ on first build of base Johnson, Andrew N. via Tech-talk

Navigate by Date:
Prev: Re: asynError in write on Power PMAC IOC Chanaka via Tech-talk
Next: Re: asynError in write on Power PMAC IOC giles.knap--- via Tech-talk
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <2019
Navigate by Thread:
Prev: Re: asynError in write on Power PMAC IOC Chanaka via Tech-talk
Next: Re: modules/ca/src/perl cc1: error: ‘-fcf-protection=full’ on first build of base Matt Newville via Tech-talk
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <2019
ANJ, 09 Jan 2019 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·