Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
<== Date ==> <== Thread ==>

Subject: striptool strangeness
From: "Laznovsky, Michael" <lazmo@slac.stanford.edu>
To: "TECHTALK" <tech-talk@aps.anl.gov>
Cc: "Laznovsky, Michael" <lazmo@slac.stanford.edu>
Date: Wed, 21 Sep 2005 18:14:49 -0700
Hi all-

For a while now I've noticed an odd effect in one of my ongoing striptool
charts... one of the PVs I follow starts at zero when an IOC is booted and 
just counts up from there, one step every 3.7 seconds or so, as you can see 
on this full-scale chart ("LM20:DATA:COUNT", the diagonal maroon line):

http://www-user.slac.stanford.edu/lazmo/tmp/lm20-stripbug2.gif

But when striptool is set to user-specified axis limits, that PV mysteriously
keeps regularly reappearing in the interval (0,100) as though it had been
reset to zero:

http://www-user.slac.stanford.edu/lazmo/tmp/lm20-stripbug.gif

The phantom period looks to be about 5.5 hours, which translates to about
19800 seconds, or 5300 counts of the PV; apparently not an obvious power-of-2 
wrap-around effect in this case.

Haven't seen any other PVs do this, but then I don't follow any other
monotonically-increasing ones.  No big deal, unless it reveals some underlying
bug that may be subtly affecting other displays.

Any ideas??

thanks, 
Mike

-----
Michael P. Laznovsky                         mailto:lazmo@slac.stanford.edu
Application Software Developer, ESD                     ofc: (650) 926-2924
Stanford Linear Accelerator Center, MS-46               fax: (650) 926-3515
2575 Sand Hill Road, Menlo Park CA 94025 USA   http://www.slac.stanford.edu


Replies:
Re: striptool strangeness Dirk Zimoch

Navigate by Date:
Prev: Re: Error using Agilent E5810A LAN/GPIB Gateway Benjamin Franksen
Next: scan task stack overflow Geoff Savage
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
Navigate by Thread:
Prev: Re: Error using Agilent E5810A LAN/GPIB Gateway Benjamin Franksen
Next: Re: striptool strangeness Dirk Zimoch
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
ANJ, 02 Sep 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·