Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  <20112012  2013  2014  2015  2016  2017  2018  2019  2020  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  <20112012  2013  2014  2015  2016  2017  2018  2019  2020 
<== Date ==> <== Thread ==>

Subject: RE: EDM Installation Error
From: "Allison, Stephanie" <saa@slac.stanford.edu>
To: Ed Villasenor <villasenor@aetjapan.com>, John William Sinclair <sinclairjw@ornl.gov>, "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Wed, 14 Dec 2011 08:41:59 -0800
Hi Ed,

This sounds like something discussed in these tech-talk messages:

http://www.aps.anl.gov/epics/tech-talk/2008/msg00356.php
http://www.aps.anl.gov/epics/tech-talk/2008/msg00357.php

We had the font init problem when upgrading to RHEL6 and applied the solution from msg00357.

Stephanie Allison

> -----Original Message-----
> From: tech-talk-bounces@aps.anl.gov [mailto:tech-talk-bounces@aps.anl.gov] On Behalf
> Of Ed Villasenor
> Sent: Tuesday, December 13, 2011 9:30 PM
> To: John William Sinclair; tech-talk@aps.anl.gov
> Subject: Re: EDM Installation Error
> 
> Dear John,
> 
> I was able to compile edm by changing the const char to char.
> Unfortunately when I try to start EDM, "Font init failed - abort" error
> is displayed. Do you know if this error is related to the remFileOpen.cc
> file that I altered.
> 
> Regards,
> Ed
> 
> --
> Ed Villasenor <villasenor@aetjapan.com>
> 
> 
> On Mon, 05 Dec 2011 09:33:26 -0500
> John William Sinclair <sinclairjw@ornl.gov> wrote:
> 
> > Ed,
> >
> > The problem is that some versions of g++ require a cast of the form
> > (const char *)
> > and others require (char *). Try editing the file and changing the
> > offending lines from
> > one of those forms to the other.
> >
> > John Sinclair
> >
> > Ed Villasenor wrote:
> > > Dear All,
> > >
> > > I'm currently installing EDM on a CentOS 6 laptop and came accross the
> > > same problem described here:
> > > hxxp://www.aps.anl.gov/epics/tech-talk/2010/msg00157.php
> > > and hxxp://www.aps.anl.gov/epics/tech-talk/2009/msg01681.php
> > >
> > > Has the solution for this problem been found?
> > >
> > > Additional Info
> > >  - EPICS Base: 3-14-11
> > >  - EDM: 1-11-2i
> > >  - installed
> > > 	epics base
> > > 	medm
> > > 	libpng-1 . 2 . 6rc1-config . tar . gz
> > > 	libungif-4 . 1 . 3 . tar . gz
> > > 	giflib-4 . 1 . 3 . tar . gz
> > > 	zlib-1 . 2 . 5 . tar . gz
> > > 	openmotif-2 . 3 . 3-1 . el4.5.i386.rpm
> > > 	openmotif-devel-2 . 3 . 3-1 . el4.5.i386.rpm
> > >
> > > I have previously installed EDM on a CentOS 5 Workstation without having
> > > this problem.
> > >
> > > Kind Regards,
> > >
> >
> 



References:
EDM Installation Error Ed Villasenor
Re: EDM Installation Error Ed Villasenor

Navigate by Date:
Prev: Re: Tektronix 3000/5000 oscilloscopes Pavel Masloff
Next: Re: synApps 5.6 release J. Lewis Muir
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  <20112012  2013  2014  2015  2016  2017  2018  2019  2020 
Navigate by Thread:
Prev: Re: EDM Installation Error Ed Villasenor
Next: problem using shell command in EDM Maurizio Montis
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  <20112012  2013  2014  2015  2016  2017  2018  2019  2020 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·