Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020 
<== Date ==> <== Thread ==>

Subject: Occasional autoscaling problem in Display Builder Plot
From: "Gregory, Ray" <gregoryrd@ornl.gov>
To: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Wed, 23 May 2018 13:21:02 +0000

I have a plot in a Display Builder UI. The trace on the plot is defined using PVs that change based on user selections. I have autoscaling enabled for both X and Y axes. However, sometimes when the data changes the scaling does not change to fit the data, but all I need to do is reload the display or change something on the plot (e.g. showing/hiding the toolbar) in order to trigger the proper autoscaling. Is there a way to make the autoscaling more reliable?

 


Navigate by Date:
Prev: RE: [UNTRUSTED] Problem accessing TextUpdate text property in Display Builder script. Gregory, Ray
Next: Re: msi "Could not open" error on Windows with file absolute path J. Lewis Muir
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020 
Navigate by Thread:
Prev: Re: msi "Could not open" error on Windows with file absolute path J. Lewis Muir
Next: Leica laser tracker integration with EPICS Hartman, Steven M.
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  2020 
ANJ, 23 May 2018 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·