Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <20192020  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <20192020 
<== Date ==> <== Thread ==>

Subject: Re: Problem with ADURL reading .jpg image from server
From: Mark Rivers via Tech-talk <tech-talk@aps.anl.gov>
To: "Wlodek, Jakub" <jwlodek@bnl.gov>
Cc: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Wed, 31 Jul 2019 15:19:49 +0000
Hi Jakob,

I believe that GraphicsMagick uses the file extension to determine the format. It looks like URL does not have a .jpg extension?

Mark


Sent from my iPhone

On Jul 31, 2019, at 8:56 AM, Wlodek, Jakub via Tech-talk <tech-talk@aps.anl.gov<mailto:tech-talk@aps.anl.gov>> wrote:

Hi all,

I have been working with the ADURL driver to set up an IOC for an analog camera here at NSLS2. I have the IOC set up and running, and I can read .jpg files without issue locally on the ioc server.

However, when I enter the URL for the image coming from the camera, the driver does not get images, and when I stop acquisition, I get the following error message:

------------------------
10:48:39 74:30 39.180u 3390 constitute.c/GmReadImage/1535/MissingDelegate:
  No decode delegate for this image format (/tmp/gmmxs23m)
2019/07/31 10:48:39.033 URLDriver:readImage: error reading URL=URLDriverApp: No decode delegate for this image format (/tmp/gmmxs23m) reported by ../constitute.c:1535 (GmReadImage)
------------------------

I tested putting the url I gave the IOC into a web browser and it correctly opened a jpeg image. I also downloaded said image to the local machine and pointed at it: /home/jwlodek/image.jpg, and the ADURL IOC
processed it without issue. My guess is that when reading the url from the server the ADURL driver is not actually seeing a .jpg file, which is causing it to say that there doesn't exist a decode format for it.

Has anyone else ran into this issue before, and if so would you be able to share the solution?

Regards,
Jakub Wlodek

Replies:
Re: Problem with ADURL reading .jpg image from server Wlodek, Jakub via Tech-talk
References:
Problem with ADURL reading .jpg image from server Wlodek, Jakub via Tech-talk

Navigate by Date:
Prev: Fwd: Help required Andrew Johnson via Tech-talk
Next: Re: Problem with ADURL reading .jpg image from server Wlodek, Jakub via Tech-talk
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <20192020 
Navigate by Thread:
Prev: Problem with ADURL reading .jpg image from server Wlodek, Jakub via Tech-talk
Next: Re: Problem with ADURL reading .jpg image from server Wlodek, Jakub via Tech-talk
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <20192020 
ANJ, 31 Jul 2019 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·