Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019 
<== Date ==> <== Thread ==>

Subject: newport mm4000 motor record hardware(gpib/serial) needs
From: Zhijian Yin <zyin@bnl.gov>
To: TECHTALK <tech-talk@aps.anl.gov>
Date: Fri, 12 Dec 2003 12:50:21 -0500
What's the hardware requirements for Newport MM4000/3000 to work under motor record? Currently we have mm3000/4000 work with SPEC/gpib (pci card under linux). We'd like to have a VME gpib or serial card and put MM4000/3000 in motor record.

My question is: What kind of VME gpib/serial card should I get? We have vxWorks 5.3 (BSP mvme-2304, ppc604) and I was able to built epics3.13.9 on it (using the Linux cross compiler from sns).

From motor record (motor4-7-4) src, it seems it needs mpf-gpib (which supports SBS IP-488) or mpf-serial (SBS OctalUART serial IP module). But then Mark Rivers MM4000 site (http://cars9.uchicago.edu/software/epics/dev_mm4000.html) says it also works with NI-1014.

Can some one who has used it provide some detail on the hardware it needs?


Thanks!



Zhijian Yin NSLS, zyin@bnl.gov









Navigate by Date:
Prev: RE: Spurious link alarms generated? J. Frederick Bartlett
Next: RE: newport mm4000 motor record hardware(gpib/serial) needs Mark Rivers
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019 
Navigate by Thread:
Prev: Re: Insertion Devices Control and EPICS Allan Honey
Next: RE: newport mm4000 motor record hardware(gpib/serial) needs Mark Rivers
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  <20032004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019 
ANJ, 10 Aug 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·