Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
<== Date ==> <== Thread ==>

Subject: Re: VxWorks5.5 on MVME230x doesn't reestablish broken N/W link
From: "Ernest L. Williams Jr." <ernesto@ornl.gov>
To: Andreas Isenegger <andreas.isenegger@psi.ch>
Cc: EPICS tech-talk <tech-talk@aps.anl.gov>
Date: Wed, 28 Sep 2005 18:55:30 -0400
On Wed, 2005-09-28 at 17:12 +0200, Andreas Isenegger wrote:
> Hello All,
> 
> Since I posted 2 e-mails in July 2005 seeking for help, I thought it would 
> be worth informing you that the problem could be solved.
> 
> There are indeed some bugs in Wind River's N/W driver (dec21x40End.h/c) that 
> cause the misbehavior of the IOC. I got new revisions of these files from 
> Martin Niedermair, WRS Austria, which solve the issue. Strangely enough, a 
> different support engineer of WRS sent me another revision of the same 
> files, which doesn't fix the bug. About 2 years back, they were branched... 
> . The latest official patch from WRS contains again different revisions of 
> the files.
> 
> Thus, if you are experiencing troubles with IOC's disconnecting for 'no 
> reasons', or reset ports of N/W switches to regain links to IOC's, build a 
> new VxWorks image with the latest revision of these files.
Can you send us a copy of the files or give us a rev. number to compare
against?

I think we are fine but I want to double-check.

Our MVME2101s also use the "dec21x40End.h/c"


PS: Did WRS give you a TSR or SPR that we could look up on our end?


Thanks,
Ernest L. Williams Jr.
SNS Control Systems Group
ORNL



> 
> Kind regards,
> Andreas Isenegger
> 
> ----------------------------------
> Andreas Isenegger
> SLS Controls
> Paul Scherrer Institute, WSLA/207
> CH-5232 Villigen PSI, Switzerland
> Tel/Fax: ++41 (56) 310 5125/4413
> ---------------------------------- 
> 


Replies:
Re: VxWorks5.5 on MVME230x doesn't reestablish broken N/W link Andreas Isenegger
References:
VxWorks5.5 on MVME230x doesn't reestablish broken N/W link Andreas Isenegger

Navigate by Date:
Prev: Re: VxWorks TIMEZONE hack, anyone? Steven Hartman
Next: Re: VxWorks5.5 on MVME230x doesn't reestablish broken N/W link Andreas Isenegger
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
Navigate by Thread:
Prev: VxWorks5.5 on MVME230x doesn't reestablish broken N/W link Andreas Isenegger
Next: Re: VxWorks5.5 on MVME230x doesn't reestablish broken N/W link Andreas Isenegger
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  <20052006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  2019  2020 
ANJ, 02 Sep 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·