Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019 
<== Date ==> <== Thread ==>

Subject: RE: Problems with areaDetector Prosilica driver on Windows?
From: Mark Rivers <rivers@cars.uchicago.edu>
To: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Cc: "kjbaldwin@notes.cc.sunysb.edu" <kjbaldwin@notes.cc.sunysb.edu>
Date: Thu, 14 Jun 2012 14:11:53 +0000
An APS beamline with a new Prosilica system reported this same problem yesterday.  They were running areaDetector R1-8beta1 prebuilt for win32-x86 on a Windows XP system.  

When I looked at the system it was indeed displaying the behavior I have heard reported elsewhere.  Changing AcquireTime and AcquirePeriod did not have any effect, though the readbacks displayed the new value.  When restarting the IOC the new values did take effect.

However, I then changed the BinX and BinY, and those changes did take effect immediately.  I also changed MinX and MinY to 0.  To my surprise, after doing that then everything worked fine! Changing AcquireTime and AcquirePeriod had immediate effect, even without stopping acquisition.

At that point I exited the IOC application and restarted it.  Changing AcquireTime and AcquirePeriod still worked normally, the problem seemed to have disappeared!

I can't explain the problem, so I don't know if it's in my software, their library, or their firmware.  It is very hard to reproduce, since I don't think I can make that system fail again now.

Yan Fen and Ken, please try this and see if it fixes the problem for you as well.

Cheers,
Mark




From: Mark Rivers 
Sent: Friday, June 08, 2012 7:16 AM
To: tech-talk@aps.anl.gov
Cc: yanfen@sinap.ac.cn; kjbaldwin@notes.cc.sunysb.edu
Subject: Problems with areaDetector Prosilica driver on Windows?

Folks,
 
I have now have 2 reports of problems with the R1-7 areaDetector Prosilica driver on Windows.  
 
The reported problem is that when making any changes to things like the exposure time, exposure period, color mode, etc. the values do not take effect immediately, but only after restarting the IOC.
 
I cannot reproduce the problem on my systems.
 
Has anyone else seen such a problem?  If so, can you please tell me what OS (XP, Windows 7, 32 or 64 bit, etc.).
 
Thanks,
Mark
 


Replies:
RE: Problems with areaDetector Prosilica driver on Windows? Mark Rivers
References:
Problems with areaDetector Prosilica driver on Windows? Mark Rivers

Navigate by Date:
Prev: Re: streamdevice: error handling for multiple lines of input from one command Dirk Zimoch
Next: Problem with EPICS c# Library Version 1.2.0.0 张玉亮
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019 
Navigate by Thread:
Prev: Problems with areaDetector Prosilica driver on Windows? Mark Rivers
Next: RE: Problems with areaDetector Prosilica driver on Windows? Mark Rivers
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  2018  2019 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·