Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019 
<== Date ==> <== Thread ==>

Subject: Re: GpibBoardDriverConfig not found
From: Mark Rivers <rivers@cars.uchicago.edu>
To: Vishnu Patel <vishnu.patel@rediffmail.com>, techtalk <tech-talk@aps.anl.gov>
Date: Mon, 9 Apr 2018 11:51:24 +0000
Hi Vishnu,


I suspect that your application Makefile is missing a line like this:


myIOCApplication_DBD += drvLinuxGpib.dbd


Or, if you are using an applicationInclude.dbd file then it needs this

include "drvLinuxGpib.dbd"


Mark



________________________________
From: tech-talk-bounces@aps.anl.gov <tech-talk-bounces@aps.anl.gov> on behalf of Vishnu Patel <vishnu.patel@rediffmail.com>
Sent: Monday, April 9, 2018 6:07 AM
To: techtalk
Subject: GpibBoardDriverConfig not found

Hi,
    I am using linux-gpib-4.1.0 to access GPIB devices with Agilent 82357B GPIB-USB adaptor.
With ibtest i can access GPIB instrument without any error.

But making IOC as given in
https://wiki-ext.aps.anl.gov/epics/index.php/How_to_use_GPIB_ports_with_linux-gpib_and_StreamDevice


with LINUX_GPIB=YES in asyn4-33/configure/RELEASE

considering
https://epics.anl.gov/tech-talk/2007/msg01343.php
https://epics.anl.gov/tech-talk/2008/msg00008.php


The gpib library
$ ls /lib/
apparmor/                             klibc-k3La8MUnuzHQ0_kG8hokcGAC0PA.so  systemd/
brltty/                               libgpib.so.0                          sysvinit/
cpp                                   linux-sound-base/                     terminfo/
crda/                                 lsb/                                  udev/


but
$ /sbin/ldconfig -p |grep gpib

doesn't list any gpib library.



But still i am getting and error

## 2 Configure your asynPorts
# 2a GPIB: portname, autoConnect, boardId, timeout, 5th_arg
     GpibBoardDriverConfig("agi", "1", "0", "3", "0")
st.cmd line 18: Command GpibBoardDriverConfig not found.
## Load record instances
dbLoadTemplate "db/user.substitutions"


i am using it on ubuntu 16 with 64 bit machine.

Thanks
Vishnu

Replies:
Re: GpibBoardDriverConfig not found Vishnu Patel
References:
GpibBoardDriverConfig not found Vishnu Patel

Navigate by Date:
Prev: Re: Problem with autosave module making it crash at random basis. Mark Rivers
Next: Re: SMA100A Signal Generatordriver Benjamin Franksen
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019 
Navigate by Thread:
Prev: GpibBoardDriverConfig not found Vishnu Patel
Next: Re: GpibBoardDriverConfig not found Vishnu Patel
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  <20182019 
ANJ, 10 Apr 2018 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·