Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017  2018  2019  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017  2018  2019 
<== Date ==> <== Thread ==>

Subject: Re: 2 MAXv problems
From: Ron Sluiter <sluiter@aps.anl.gov>
To: Jens.Eden@ptb.de
Cc: tech-talk@aps.anl.gov
Date: Mon, 08 Mar 2010 15:18:33 -0600
Hello Jens,

The common code for the old device support record
initialization; "motor_init_record_com()" was not always
passing positive encoder ratio values.  This has been a
bug for a long, long time that is now fixed.

I have also conditionally added your fix for sprintf()
not callable from the RTEMS interrupt context to the
MAXv ISR.

Both of these changes will be available, soon, in the
next release.

Thanks for pointing out these problems,
Ron


Jens.Eden@ptb.de wrote:
Hello Ron,

but the motor record has not issued negative
encoder ratio commands for a long time.
here is an extract of the boot messages with drvMAXvdebug=10, while autosave writes -5.55123456e-06 to the ERES-field.

--
send_mess: sent card 0 message:'
AX  ER-180140,52359 UU-3.440496
--
This command (ER-180140,52359) does not work for
current firmware versions.

Are you using a really old
version of the motor record?
No, this is the motorR6-4-4
EpicsRelease 3.14.11


Jens
_______________________________
Jens Eden
Physikalisch-Technische Bundesanstalt
Albert-Einstein-Straße 15
12489 Berlin

Tel +49 30 6392-5086
Fax +49 30 6392-5082




Von: Ron Sluiter <sluiter@aps.anl.gov> An: Jens.Eden@ptb.de Kopie: tech-talk@aps.anl.gov Datum: 05.03.2010 21:12 Betreff: Re: 2 MAXv problems



Hello Jens

There has been a recent (R6-4 and above) fix to prevent intermittent MAXv command
errors from occurring when User Units are turned off, but the motor record has not
issued negative encoder ratio commands for a long time. Are you using a really old
version of the motor record?


Ron


Jens.Eden@ptb.de wrote:
Hi all,

I found, that in recent firmware versions (1.31) of the MAXv cards the command to set
negative encoder resolutions (e.g. "AX ER-2,3") as used by the MAXv
driver
does not work any more.
Instead a command error is returned and the encoder resolution will
remain
unchanged.
I couldn't find this "new feature" documented anywhere.






References:
2 MAXv problems Jens . Eden
Re: 2 MAXv problems Ron Sluiter
Re: 2 MAXv problems Jens . Eden

Navigate by Date:
Prev: Re: IOC with LOTS of serial ports David Kline
Next: edm1-12-27 installation problem Hiren Patel
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017  2018  2019 
Navigate by Thread:
Prev: Re: 2 MAXv problems Jens . Eden
Next: Re: 2 MAXv problems Ron Sluiter
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017  2018  2019 
ANJ, 02 Sep 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·