Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <20192020  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <20192020 
<== Date ==> <== Thread ==>

Subject: re:EPICS Docker Container
From: Jack Harper - UKRI STFC via Tech-talk <tech-talk@aps.anl.gov>
To: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Mon, 8 Jul 2019 12:20:50 +0000
Hi Florian,

Have you exposed your ports in the Dockerfile correctly?

I have just fixed this in one of the Dockerfiles i have been working on - here is the line that exposes the ports:

EXPOSE 5064 5065 5064/udp 5075 5076 5075/tcp 5076/udp

I had to be explicit that i was exposing 5075 as tcp and 5076 as udp - pv access would not work otherwise. I just run the container with no arguments and it seems to work.

Hope this helps,
Jack Harper




Navigate by Date:
Prev: EPICS Docker Container Florian Feldbauer via Tech-talk
Next: Re: EPICS Docker Container Florian Feldbauer via Tech-talk
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <20192020 
Navigate by Thread:
Prev: Re: EPICS Docker Container Florian Feldbauer via Tech-talk
Next: Re: EPICS Docker Container Florian Feldbauer via Tech-talk
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  2018  <20192020 
ANJ, 10 Jul 2019 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· Search · EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·